Entender La Función SI Anidadas

Función SI: Fórmulas anidadas y cómo evitar problemas

La función SI le permite realizar una comparación lógica entre un valor y el resultado que espera probando una condición y devolviendo un resultado si es Verdadero o Falso.

=SI(Algo es Verdadero, hacer algo; de lo contrario hacer algo diferente)

Por esto, una instrucción SI puede tener dos resultados. El primer resultado es si la comparación es Verdadera y el segundo si la comparación es Falsa. “Anidamiento” hace referencia a la práctica de unir varias funciones en una fórmula.

Observaciones

Aunque Excel permite anidar hasta 64 funciones SI() distintas, no se recomienda hacerlo. ¿Por qué?

El uso de varias instrucciones SI() requiere una cuidada planificación para crearlas correctamente y asegurarse de que su lógica puede calcular sin errores cada una de las condiciones hasta llegar al final. Si no anida su fórmula con una precisión absoluta, podría funcionar en el 75 % de los casos pero devolver resultados inesperados en el 25 % restante. Lamentablemente, las probabilidades de detectar ese 25 % de casos son muy escasas.

Ejemplo:

=SI(D2>89,"A",SI(D2>79,"B",SI(D2>69,"C",SI(D2>59,"D","F"))))

Este instrucción SI anidada compleja sigue una lógica sencilla:

  • Si el resultado (en la celda D2) es mayor que 89, la calificación es A
  • Si el resultado es mayor que 79, la calificación es B
  • Si el resultado es mayor que 69, la calificación es C
  • Si el resultado es mayor que 59, la calificación es D
  • En caso contrario, la calificación es F.

Ver Referencia en esta imagen.

Si anidadasAbre Excel Ahora y practica con la funcion `Si` anidada!!!
Suerte!!!